PDA

View Full Version : Two Segelei 20 watts Vw/VV mods fail



cymric
01-07-2015, 03:15 AM
I loved my two Sigelei 20 watts. They both have failed within a week of each other. Unfortunately I have owned them 6.5 months and 8 months respectively - just past the point of return. Yes, they have been used a lot, but I think this is a bit early to fail. Somehow the power is not connecting with any of the four Kanger tanks. Sad. I expected better of Sigelei.

vincom
01-07-2015, 11:18 AM
I loved my two Sigelei 20 watts. They both have failed within a week of each other. Unfortunately I have owned them 6.5 months and 8 months respectively - just past the point of return. Yes, they have been used a lot, but I think this is a bit early to fail. Somehow the power is not connecting with any of the four Kanger tanks. Sad. I expected better of Sigelei.
do they turn on at all, any signs of life
if they are not firing your atomizers then check the 510 connector center pin(most likely the problem) or try a different brand of atomizer to test connection

cymric
01-08-2015, 06:58 PM
do they turn on at all, any signs of life
if they are not firing your atomizers then check the 510 connector center pin(most likely the problem) or try a different brand of atomizer to test connection

I have checked the firing pin to the extent I am able (it still has spring and is clean) - any suggestions on how else to check it apart from a meter? If it is the pin, how does one fix it?

I have tried many atomizers (all which work on another mods). The programs come up on the screens and say all the right things but they do not fire

PS - both of the pins fail within a week!

>