Welcome guest, is this your first visit? Click the "Create Account" button now to join.

Welcome to the Wackedout - Ecig Canada Forum Electronic Cigarette.

If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

User Tag List

Results 1 to 8 of 8
  1. #1
    Coach ronjamesmajor's Avatar
    Join Date
    May 2013
    Location
    Hanna, Alberta
    Posts
    179
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    VaporBreak Omega Clone.

    Hey all... I didn't really search through the forum as I just got this thing in the mail and I've got a question.

    The firing mechanism sticks on it. sticks "compressed" so it's "firing" always when I press the plunger down.

    Does anyone have experience with this clone and how I could possibly mod this out so that it works as it's supposed to?

    Thanks in advance...I can post pics if necessary.

  2. #2
    Staff Moderator Nubbie's Avatar
    Join Date
    Dec 2012
    Location
    Calgary
    Posts
    2,363
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    so I looked at the photos on the site, is it a top button push to fire?

  3. #3
    Guru Trainer Switcher's Avatar
    Join Date
    Dec 2012
    Location
    Dartmouth, NS
    Posts
    2,300
    Post Thanks / Like
    Mentioned
    71 Post(s)
    Tagged
    0 Thread(s)
    Seems like they cloned on of the faults of the original as well

  4. #4
    Coach ronjamesmajor's Avatar
    Join Date
    May 2013
    Location
    Hanna, Alberta
    Posts
    179
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I guess it could be considered a top button design. Essentially the 510 connector part on the top has a black plastic or delrin or something plug in it. which comresses downward pushing a small brass firing pin onto the top of the battery. When there's an atty attached it's supposed to look like it "squeezes together" in the middle.

    VaporBreak Omega Clone.-20130716_131151-1-jpgVaporBreak Omega Clone.-20130716_131158-1-jpgVaporBreak Omega Clone.-20130716_131209-1-jpg


    If I push the black bit upwards towards the connection when I push the firing mechanism it does some to pop back out on it's own. I am thinking perhaps the black bit is supposed to be press fit or glued into place, and isn't? I bought a second as well which seems to work as advertised.

  5. #5
    Guru Trainer Switcher's Avatar
    Join Date
    Dec 2012
    Location
    Dartmouth, NS
    Posts
    2,300
    Post Thanks / Like
    Mentioned
    71 Post(s)
    Tagged
    0 Thread(s)
    here ya go. The clone is V2 of the Omega. The alpha depicted below might be what you have.


  6. #6
    Coach ronjamesmajor's Avatar
    Join Date
    May 2013
    Location
    Hanna, Alberta
    Posts
    179
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Wow, that was a fast fix. Thanks Switcher.

    I grabbed a knife out of the drawer in the breakroom and popped that delrin piece out.
    As soon as I did that the firing mechanism immediately compresses and springs back the way it is supposed to.
    My guess is the cheap QA they do on these, the delrin piece is wicked jaggy in the middle, and doesn't allow smooth action through the center hole for the firing pin.
    Problem should be an easy enough solution when I get home tonight.

    Thanks again. I'll update when re-drill / clean the center hole. If anyone else has these issues.

  7. #7
    Coach ronjamesmajor's Avatar
    Join Date
    May 2013
    Location
    Hanna, Alberta
    Posts
    179
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)

    Re: VaporBreak Omega Clone.

    K so definitely not a beautiful fix but a fix never the less. After fighting with the delrin bit after getting home I drilled a little pull hole and got it out. Them used a 1/8 drill bit to widen the contact hole and now it's firing alot better. Still not perfect, and I might need to drill out a little more then sand it back smooth but this is working for now. Will post pics after, as Tapatalk is not letting me upload photos for some reason.

    Thanks again those with fast responses!

    Sent from my SGH-I717D using Tapatalk 4 Beta

  8. #8
    Mentor
    Join Date
    Jul 2019
    Location
    Waterloo, ON
    Posts
    318
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for posting!

 

 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Our Partners

VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.VaporBreak Omega Clone.

Electronic Cigarette Directory
Chilliwack & Agassiz Dentist
Buy CBD Canada Online